There is a delay in presenting new data in Admin Console
Incident Report for PerimeterX
Resolved
This incident has been resolved.
Posted almost 2 years ago. Jul 20, 2017 - 06:27 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted almost 2 years ago. Jul 19, 2017 - 22:44 UTC